友之介的つぶやきブログ

PCやらプログラムやらぶつぶつ言ってます

UE4

下のサイトを参考にUnreal Engine4をインストールしてみました。

 

Linux Quick Start Guide | Unreal Engine

Building On Linux - Epic Wiki


手順にどおりに
./Setup.sh
実行したのですが、clangのバージョンが違うみたいで先に進めないようです。

下のサイトを参考に
Engine/Build/BatchFiles/Linux/Setup.sh
を修正したら、無事インストールでしました。

Run Unreal Engine 4 on Ubuntu 16.04 | The Ubuntu Addict

 



新年

あけましておめでとうございます。
本年もよろしくお願いします。

 

vmplayerのwindows10でShared Folders

vmplayerのwindows10でShared Foldersが見えないのでネットで検索すると
下記サイトを発見。

https://communities.vmware.com/thread/524951?tstart=0



書いてる通り設定で無事見えるようになりました。


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet001\Control\NetworkProvider\Order
Name: ProviderOrder
Type: REG_SZ
Data: "vmhgfs,RDPNP, LanmanWorkstation,webclient"

 

コンパイルエラー

いつもの如く、debianをupdateしたら、direct renderingが使えない状態に。
nvidiaドライバをインストールしようとするとエラーが。
モジュールのコンパイル中のエラーのようだ。

試しにカーネルコンパイルしてみるも

error: code model kernel does not support PIC mode

というエラーが。

ネットで調べてみると、下記のサイトを発見。

 

kali linux - Cannot compile kernel: error, kernel does not support PIC mode - Unix & Linux Stack Exchange



Makefileを修正し、インストールしたら無事できました。

synapticが起動しない

久しぶりにsynapticを起動したら下記のエラーが出力されて起動できず。

terminate called after throwing an instance of 'Xapian::FeatureUnavailableError'


ネットで調べていると下の書き込みを発見。

https://lists.debian.org/debian-user/2016/10/msg00359.html



書いてあったコマンド

update-apt-xapian-index

を実行。

無事起動できるようになりました。

 

Open Jtalkを試す

フリーの音声合成ソフトOpen Jtalkを試してみました。

とりあえず、インストールし色々なサイトをみてコマンドラインから実行。

echo "てすと" | open_jtalk -m /usr/share/hts-voice/nitech-jp-atr503-m001/nitech_jp_atr503_m001.htsvoice -x /var/lib/mecab/dic/open-jtalk/naist-jdic/ -ow tmp.wav && aplay tmp.wav

簡単にしゃべらせることが出来ました。

音響モデルを変えることができるみたいなので、下のURLからダウンロード。

 

http://www.mmdagent.jp/


女性音声に変更出来ました。

全体の高さを上げることは、パラメータでできるみたいですが、
個々の高さは変えられないのかな?

起動が遅い

いつもの如く、debianをupdateした後、再起動すると、起動が少し遅い。

systemd-analyze blame
で調べてみると、networking.serviceが4秒かかっているみたい。

以前もこんなことがあったので、記憶とバックアップから調べてみる。
udevadmが遅かったことを思い出し。

/lib/systemd/system/networking.service

ExecStartPre=-/bin/sh -c '[ "$CONFIGURE_INTERFACES" != "no" ] && [ -n "$(ifquery --read-environment --list --exclude=lo)" ] && udevadm settle'

を変更
ExecStartPre=-/bin/sh -c '[ "$CONFIGURE_INTERFACES" != "no" ] && [ -n "$(ifquery --read-environment --list --exclude=lo)" ]'


無事、元の速度に戻りました。

今度は忘れずブログにメモしておきます。