読者です 読者をやめる 読者になる 読者になる

友之介的つぶやきブログ

PCやらプログラムやらぶつぶつ言ってます

kernel4.0.0

linux

最近話題のkernel4.0.0を試すためにコンパイルしてみました。
いつもどおり、make oldconfigをしてコンパイル
起動してみると、カーネルパニックで起動せず。
そういえば、3.18の時も同じだったような。

色々試していると、Kernel compression modeをLZ4にしていると起動できないみたいです。

コンフィグを検索してると、Compressed RAM block device supportという項目が……
どうやら圧縮関係が変わったみたいですね。

と、言うことで下記のZRAM関係の設定を全てYに。

CONFIG_ZSMALLOC
CONFIG_ZRAM
CONFIG_ZRAM_LZ4_COMPRESS

無事にLZ4でも起動できるようになりました。